Probleme beim Spielen mit dem heruntergeladenen Clienten



  • Mein Betriebssystem ist Win7 - 64bit.

    Zuerst möchte ich darauf hinweisen, dass das Spielen mit der, laut der Datei "version", Standartversion 0 sowohl im Single- als auch im Multiplayer möglich ist, wenn nicht CatanLauncher.exe sondern CatanUniverse.exe gestartet wird. Dabei fehlt der Content der wohl durch die Updates hinzugefügt wird, wie beispielsweise die S&R + Seefahrer-Szenarien und in verschiedenen Auflösungen flakern ab und zu verschiedene Grafiken. - Eventuell nicht erwünscht, dass auch alte Versionen spielbar sind.

    Nach Starten der CatanLauncher.exe wird der ein Patch heruntergeladen, mit dem anschließend ein Update auf Version 1.00.2 durchgeführt wurde. Laut Versions-Datei ist die neue Version die Version 2. Der Versuch das Spiel danach mit CatanLauncher.exe oder CatanUniverse.exe zu starten resultiert in einer Failed to initialize player - Fehlermeldung mit den Details: Could..... not preload global game manager #0 i=0

    Ich habe bereits versucht den Client sowohl auf den Standart also auch auf einen alternativen Dateipfad zu installieren und anschließend zu aktualisieren, beides führte zu der obigen Fehlermeldung.

    Außerdem ist mir beim manuellen ändern der Version ein kleiner Bug aufgefallen. Speichert man in der Versionsdatei eine Zahl <2, führt dies dazu, dass der Patch erneut geladen und danach das Update ausgeführt wird. Da nach dem "Update" jedoch die Version nicht auf 2 gesetzt wird, wird scheinbar nur überprüft ob etwaige Dateien fehlen und es geschieht nichts, falls alle vorhanden sind (auch die Version wird nicht auf 2 gesetzt!) Das Setzten der Version sollte meines Erachtens aus der Überprüfung rausgezogen werden und auf jeden Fall durchgeführt werden - zwar nur nebensächlich für die Funktion des Clienten aber codetechnisch auch schnell angepasst ;)
    Eine Zahl >= 2 führt zu oben genanntem Fehler.

    €: Habe gerade im englischen Forum einen Thread gefunden, wo der Fehler auch angesprochen wird und scheinbar ist auch einiges der von mir angesprochenen sachen bereits bekannt, allerdings habe ich noch keine Lösung gefunden. Falls jemand weiterhelfen kann, bitte hier posten oder verlinken - Danke! :)



  • Habe eben gesehen dass im Thread https://forum.catanuniverse.com/topic/821/update-kann-nicht-installiert-werden-fehler-1642/2 auch genau dieses Problem diskutiert wird, außerdem scheint das mit der Standartversion ebenfalls bekannt zu sein - das ganze hier könnte theoretisch also geschlossen werden. Ich werde weiterhin nach Lösungen die Augen offen halten.



  • Durch das Update funktioniert nun alles.

    Das Starten und Spielen mit der Standartversion ist allerdings immer noch möglich, entweder mit CatanUniverse.exe bzw. durch Manipulieren der Versionsdatei.


  • administrators

    @amiti Das ist auch so gewollt. Es ergibt sich immenses Fehlerpotential wenn wir erlauben würden, auf die Server mit unterschiedlichen Versionen zuzugreifen.



  • @Administrator Deswegen wollte ich auch darauf hinweisen, dass es mit veralteten Versionen immer noch möglich ist zu spielen.


  • administrators

    @amiti Danke für den Hinweis. Da habe ich wohl zu schnell über deinen Post gelesen :) Wir haben mit dem letzten Update des Clients am Donnerstag einiges an der Versionierung geändert, werden diesen Umstand aber noch einmal gesondert überprüfen.



  • ich habe mir auch den client geladen. das spiel startet, aber ich sehe teile der grafik nicht. sozusagen alles was auf dem brett lose sachen sind ... siedlungen, chips, straßen, ritter etc.
    habe versucht alle möglichen formen der grafik und auflösung zu starten ... immer das selbe :(


  • administrators

    @No-Woman-No-Cry könntest du bitte deine System-Spezifikationen hier posten. Also Betriebssystem/CPU/GPU und wie viel RAM in deinem System verbaut ist?


Log in to reply