Trade Menu default to Player Trade



  • Just today, the Trade Menu opened and defaulted to the Bank Trade. I've been playing for a while and it was always Player Trade as the default. I've mistakenly traded with the Bank because I wasn't expecting the Bank to be my default trading partner.

    How do I set the default to Player Trade when the Trade Menu is opened?



  • Same here. We both got screwed by 4:1 auto-trades with the bank. Bad Catan! Bad!



  • Same here. Done it three times now and has cost me dearly.
    No idea why they would change to default to that first. Surely offer players first and then if no one accepts, thats when you trade with the bank. Needs to be fixed ASAP



  • I had exactly the same problem. When I see these "improvements", I don't want to play.



  • Totally agree. I've been playing for over a year and have always clicked the buttons to offer a player trade. I've been screwed when the bank suddenly trades 4:1 when I had no intention of making such a trade. Needs to go back to player trade as default.



  • I agree too. I'm making a lot of mistakes because the default was changed. There should be a way at least to configure opposite



  • Same. Set it back or make a User Setting... it only brings mistakes...



  • The problem no longer exists. I don't know the exact date that the default trade option reverted back to player trades.