Single Player Games not awarding Experience Points in v2.1.0



  • 2nd UPDATE: Confirmed that this is now working in v2.1.1. Thank you!

    Since upgrading to v2.1.0, I am not receiving any experience points for either a win or a loss in Single Player games. I have not had an opportunity to try a Multi-Player game since the update. When I get a chance I will attempt to reinstall the game to see if that helps.

    I'm currently at level 21 with 7600 experience points.

    UPDATE: I tried installing the game on a completely different computer. It is still not awarding any experience points. It is also not recording games won.

    --- Dev Rossik



  • I experience the same problem. I have no idea what the problem is?



  • Hi,

    Yes! I have the same problem! I’ve played several single player games since the update, but no experience is added. I’m Level 7 with 1225 points.
    I played a guild game and also received no xp, but when I tried a multiplayer game I received points for that.
    shrug

    I’d be interested to know why and to have the problem fixed!



  • @Dirkiedick the problem is that every new version, they have regression bugs because they don’t conduct adequate testing. Sorry Catan admins, but just speaking the truth.



  • I too am experiencing (pun intended) this issue. I just began playing Catan Universe today and received a few XP from 'Arrival on Catan' but have received no more since then after a couple hours of single player games.



  • The issue has been fixed with update 2.1.1



  • I have 2.1.1 on tablet and Steam, and I’m still not getting single payer XP - did an uninstall and reinstall on tablet since that’s mostly what I play on - won 2 Great Canal Games and lost 1, should have 125 more XP but score is still the same.


Log in to reply