I can’t login after updating to 2.01

  • I can’t log in and neither can my wife, on our iPads. This is after we upgraded to 2.01. Or at least I think we did, it was very confusing. Did it upgrade itself automatically? Because when I went to the App Store it simply said open.

    It wants you to put in your password again. We tried it six or seven times, no luck. We also tried restarting the iPad. No luck.

    I guess it’s amateur hour for the developers at Catan universe.

  • administrators

    @DaveInZetland Servers were in maintenance. The maintenance is now over. You can log in now. Please make sure to download update 2.1.0

  • How do I log on?. I reset my password 5-6 times

  • @Administrator I'm having the exact same issue and I've tried to reset my password over 10 times

  • @Administrator using a new iPhone pro. Restarted phone, deleted and reinstalled app, reset password 3x and still can’t log on.

  • @Administrator Thanks. This time the Catan app displayed “update” in the App Store. We did so and it’s working fine.

  • @DaveInZetland Its the same for me right now

Log in to reply