Black Screen of Death upon opening Catan Universe on Android



  • Hi,
    I recently installed Catan Universe on my Redmi Note 9 Pro Max. As soon I open, it is stuck at a black screen and if i press back button, it shows a Hex animation like its loading, but it's really just stuck. This problem seems to be very prominent, going back last version of Catan, as I see hopping through forums to forums, with no popular feasible workaround. Is anything being done about this? or is there an existing solution i don't know about. I already tried usual options like reinstalling app or restarting phone and even downloading main obb file separately.



  • Did you try clearing the cache and data for the app? Sometimes that will help clear whatever was fouled up.



  • Yup.. I have tried all these routine tricks... clearing cache & app data, reinstalling and everything. it just opens again and for a brief time shows "resume download" with a loading bar then just a black screen. If we press back button then it shows a hex pertually trying to load something.



  • Hi @anilkm

    What Android version are you running on this device? Is the device rooted or are there any significant UI mods running? We don't have this exact device here, but the other Redmi devices we have here work just fine, so we haven't been able to reproduce this yet.



  • @Administrator I have the exact same problem. A week ago I reinstalled the game and since then it won't start. I got an OnePlus 7 Pro with Android 10.



  • @Administrator i have just upgraded to a new phone from Oneplus 3 to Oneplus Nord. My Catan Universe worked on old phone but will not launch on new phone.
    Runs Android 10 / Oxygen 10.5.4.AC01BA. Has 12GB ram Snapdragon 765G chip.


  • administrators

    @00SunTzu

    As this is a new device, we don't have it in the office for testing yet. Could you please confirm that you just see a black screen on startup, nothing else?



  • @Administrator what I get is the rotating circle of hexes but never go beyond it. Hope that helps.



  • same issue happens in my redmi note 9 . Is the only app that doesn't work in this device



  • Same issue for me after migrating from Pixel 2 to Pixel 4a running Android 10. Only this app had an issue of my 200+ apps migrated. Tried many things but still see the black screen and spinning hexes after swiping back on the black screen. I've tried restarting the phone, uninstalling and reinstalling the app, clearing the app's cache, and clearing the app's storage.



  • @Arcine what chip is in your phone?



  • I have the same problem. Sony Xperia 1ii