City Improvement Blocked in ver 2.0.0

  • @developers - screenshots are available for this bug if you aren't already aware of it, let me know and i'll mail it in.

    Here's a new bug I found immediately after loading version 2.0.0, I have not seen this in previous versions: City improvements are erroneously blocked in certain situations.

    In this situation a human player who has 5 coin in their hand cannot make an advancement in Politics from the 3rd to the 4th (Metropolis) level. The human player has a total of 3 cities on the board, only one of his cities has a Metropolis, so there should not be any reason the advancement is blocked.

    The way the bug presents itself is that the game does not even show the option of an advancement in Politics when left clicking on a city. In this case the possibility for an advancement in Science is not displayed because the player has already maxxed out at 5 city improvements. It does show an advancement in Trade is possible, but blocked because the player does not have enough Cloth. However the player has more than enough coin, and more than enough cities to improve, and yet an advancement in Politics is not even displayed.

    version 2.0.0-15974e8e7

  • administrators

    @huck42 Thank you very much for the feedback. Have you played the cran card before the issue appeared?

  • @Administrator I experienced the same issue (unable to improve city despite having sufficient commodities) and no, I had not played the Crane card before the issue appeared.

  • Same issue here. And even worse: I had coins but option for developing politics did not show up. I desperately traded my coins for cloth. Then politics development appeared but trading development disappeared.

    I did not play crane.

    I am on iPad.

    It is getting quite frustrating here. Besides technical issues there are players deliberately blocking and insulting, and nobody cares. I would be happy to pay for getting back a functional and friendly platform like Playcatan was.

  • I'm having the same issue. It blocks city improvements when I get one of them up to level 3. At that point I can't improve anything. I had 4 cloth and 5 paper and when I tried to upgrade either one...both disappeared...only build wall and politics was visible. Playing on iPhone.

  • Same issue. Traded resources to buy commodities to upgrade my cities. City improvements that should have been available no longer showed up for me to build a metropolis and win the game. Another player built the metropolis so I traded commodities to upgrade another area and those wouldn''t show up either. Initially was playing on computer through Steam. Switched to my iPhone and had the same issue.

  • Same issue. Seems to happen in the late states of the game for me

  • Having same issue on android, I tried to switch to desktop client and it kicked me.

  • We found a way to reproduce the issue and it will be fixed in the next update. Thank you very much for your feedback.

  • Had this exact problem, too. A workaround till they patch it is to scroll down to your city improvement "board", the one that's on the table below the game board and to the right of your ships, roads, and cities. Clicking on those sections, when this happened, allowed me to upgrade my cities. Hope I explained that well.

  • @frankenhair thank you. you are my hero

  • @Administrator

    No, this isn't about the Crane card.

    This has come up a number of times for me. One common theme I've noticed is that one player has already reached their 5th city improvement when I try to advance to level 4 in another category. For example, I have 4 cloth (and 3 cities) and try to reach the 4th level of city improvement in Politics. The game blocks that advancement when another player has reached the 5th level of Science.

  • I have the same issue. Had 5 paper and could not upgrade from 3 to 4 to get a metropolis. The option to select the upgrade was not visible. I then traded paper for coin to upgrade from level 2 to 3 there, but then that option did not appear. Each time, all of the options appeared except for the one I wanted. I was playing on a Kindle Fire HD 10. My husband had the same problem when playing on his iPad. We were both playing single player when this happened.

  • I’ve now lost multiple games to this glitch, where suddenly I can’t turn in any commodities. One game I could have won at about 5 different point but it would never let me trade. In the end I lost by one point.

  • @Braincog In reviewing our screenshots, my husband and I both noticed that each time this happened we had 4 cities. For us, no other players had reached level 5, which Huck42 noted as a common theme.

  • @Braincog I did have 4 cities at the time so maybe there’s something to that? The other players in the game had less cities and no problems trading and acquiring Metropolises.

Log in to reply