Game crashing after update



  • I just updated. I can no longer play. When I attempt to begin a single player game I never get passed the loading pages. The loading screen appears, the game freezes and then app closes. I’m on an iPad. Hope it gets fixed soon!



  • I too am playing on an iPad. Up till now, multiplayer has worked perfectly since we started playing in March. Now, after the update to v2 the app crashes the moment a settlement is placed on the board during setup. I can rejoin the game, but after about 3 crashes I get kicked out of the game permanently. This is most disappointing and needs fixing ASAP. Please respond Catan makers!



  • I am experiencing this same issue! Also on an iPad. Hope it gets fixed soon.



  • Yep, same issue over here but on a macbook and a pc. The game goes to the load screen and then says "one or more players has left the game or has a bad connection. Please try again."



  • Also experiencing same issue, has a fix been sorted yet?



  • Das geht mir ähnlich. Ich spiele als Single Player und spätestens nach 5 Zügen stürzt das Spiel ab. Ich muss es immer wieder neu starten.



  • Same here. And i just payed for the KaC expension.
    Please fix.



  • I’m having the same problem on a iPhone, can’t get past the loading screen without it crashing.



  • Of course once I pay for the actual game they update and ruin it...can’t even get a settlement on the board without crashing. I wouldn’t bother me if I didn’t love Settlers so much. Thanks for the PTSD....


  • administrators

    Our team is looking into it. I am assuming you are all playing on older iOS devices with only 1 GB or Ram?



  • @Administrator
    I’m running on an iPad Pro, during custom match as hit start game one player is kicked out, this is playing on iPads or steam on MacBook Pro, all relatively new machines



  • Iam playing on iPhone and when the game begin after 10 second it will quit automatically @Administrator



  • Just updated to v. 2.0, playing on iPhone 6, iOS 12.4.7 (thought the new update might help, did not), 64 GB, 6.29 GB free, keep trying to backup videos off my device to give more space, but got this far and still glitchy - in tutorial when try to place a road after placing first settlement, game crashes. Just tried in a Multiplayer Free Match, and crashed just after first player placed their city - an animation (waves of having placed settlement?) was about to start, but instead crashed. Please help.



  • @CHFandango Me again - had been trying to play Custom Match with a friend, thought she was using new device because she was not experiencing crashes, turns out she was also using iPhone 6 (not sure about size or storage).



  • I’m playing on an iPad. Software version 12.4.7.
    16G, 8 still available.
    The game crashes as soon as I add my beginning settlement.
    I’ve rebooted the iPad.
    I’ve uninstalled/reinstalled the game.
    I’ve cleared my cache.
    I’ve turned off the annoying zoom/camera panning feature.
    I don’t know what else to do. Please fix this game or give me my money back. I’m terribly disappointed.



  • The game was working beautifully until the new update. Now I can't play at all. I'm on an iPad and it crashes immediately. How frustrating! I am paying member and cannot access the game. It's also frustrating to lose points because the game crashes.


Log in to reply