Catan 2.0 keeps crashing!



  • Game is unplayable. Crashes as soon as the first house is placed. I am on an iPad. Software is up to date.



  • @Developers @administrators This latest update is absolute garbage. Like everyone is saying, it keeps crashing on my iPad as well. Completely unplayable. Did the development team even test this before they released it??? It is complete crap. We should get refunds and our score reset. And get your developers to test software before they release it! No excuse for this!



  • @Administrator I am having the crashing problem as well. I then tried to create a new account just so I could play with my husband. Now I can’t get into my old account! So frustrating!



  • Same for me. Crashes on first placement on first turn playing Candamir etc in single player, regardless of who places. Never had a problem before the update. iOS 12.4.6 on an iPad mini 2.



  • I also have had trouble with the crashing or stalling when the timer doesn't appear to be running. Another problem I had was that my roads were not counted correctly.



  • Bugs, bugs and more bugs! Please consider returning to the previous version.
    The games that managed to start only 60% were completed, but most of the time they simply failed to start the game.



  • Same issue here on a iPad but works fine on my Android phone. @administrators please fix for iOS devices! We love this game when it works!



  • Same for my last update is not working on my iPad



  • IOS continues to crash since Monday update- any solutions being worked. Missing my Catan....



  • Same here... :(



  • Just installed the new update but I really shouldn’t have! Can’t even start a new game now before the app quits on my iPhone 6. I normally play about 5 games/day and have done for months, I can’t believe fans like me are being screwed this way. Just restore the app to the old version or something, please!



  • Hello same problem i’m on iPhone 6 os 12.4.7. Find solution for please

    Eloi



  • SAME!!! Can't play on iPhone or Mac. it crashes as the game is about to start. Haven't been able to play 2.0 YET!
    S.O.S



  • Same here, updated to 2.0 and haven’t been able to play a single game for more than a few seconds before the app crashes. Using latest iOS



  • Hello, I have the same problèm. I can’t play Sutherland the 2.0 version. As son as I put down m’y forts housse, I am ejected. The game closes by Itself.
    I hope it will be OK soon. When ? It si so frustrating.


Log in to reply