Game not letting me open trade window or view cards.



  • So I just installed the game and it is frustrating to say the least. Im getting multiple errors:

    • When clicking on the trade icon, window opens and closes immediately. I can not do anything.
    • When clicking on cards, the scale in size and immediately scale back to normal. I can not read any cards.
    • When someone is trading with me, I can see the trade window open, but when i highlight it with my mouse, it hides immediately. I can not accept/decline trades at all
    • When tapping on development cards, same deal. I can not see the description since card scales to big size and immediately to small size.
    • When robbed is the ONLY TIME I can select the cards and click the checkbox button.
    • On end of game, I couldn't see results since game would flicker UI. If I alt tabbed out of the game (game is windowed and I could watch it from another monitor), I could see then game showed it, but when

    Video Trade window: https://i.imgur.com/3AYy5Oy.mp4
    Video End of game: https://i.imgur.com/GiRQuAN.mp4

    2 monitors (playing on 4k monitor windowed. Tried multi 1680x1050 res and 1920x1080 res). Windows 10, Steam version.

    As a note, I tried:

    • Restarting game
    • Restarting PC
    • Downloading a tool to check if my keyboard was failing, since I thought maybe a key shortcut was stuck pressed and minimizing windows. Nothing wrong with my keyboard.

Log in to reply