1 player has a different looking board in a 4 player game



  • Some of the tiles are swapped around for one player only out of 4 players. We restarted several times, logged out and logged in, same problem occurs. Even after rolling the dice, for 1 player it generates wood but for the other player it shows that the same player received ore...
    Really thought since I was paying money for this game the basics would work....might move over to colonist.io



  • I found a similar issue when I first started playing a few days ago. We installed on a few devices, established new accounts, setup a multiplayer game, and immediately noticed something odd. After testing variations of logging in the different accounts on the different devices and firing up new games, we determined the one device (iPad Air) was stuck on a board which I think it was the First Island. Easiest way to tell was position of the desert. Uninstalled then reinstalled the app on that device and that solved the issue. Now we just cross-check the bottom 3 numbers between players before starting.



  • I have the exact same issue, when playing a multiplayer game

    My friend and I manage to connect to the game, but the tile setup is not the same. We can add roads and settlements (they are put on both maps at the same location, but settlements harvest different ressources for example)

    And eventually on game ends up not responding, usually after a trading proposition (accepted or not)

    This has been 100% reproduceable in the ~10 games we attempted tonight, no matter if we reloaded, or uninstall reinstall the game

    I am running Catan Universe on iPad Pro
    My friend is running the browser client
    Both of us have the same version which is 1.9.0-dd5455c34

    Thank you for what you will do !
    We were so happy to finally be able to play together !



  • After other attempts, it appears that the issue is coming from the cross platforming

    We tried again with my friend on his phone (Android) and me still on my iPad, and then things worked smoothly

    How could this be?


Log in to reply