Players not rolling dice



  • I'm sure this issue has been complained about to death, but I'm going to voice it again. It has been increasingly frequent where I will enter a game and even upon setup a player will not place a settlement and the turn timer will end but the player will neither place a settlement nor be removed from the game to be replaced by an AI player. I've been forced to quit numerous games and ruin both my Karma and my ELO rating. For a game that has the reputation of Settlers of Catan, and the fact that many players have paid for the privilege of playing online, this issue is wholly unacceptable. This problem could simply be solved by giving players in-game power to boot a player that is having this issue. Couple this with the fact that administrators have not directly addressed this issue is deplorable.

    It is for this reason that I'm quitting this game, never to return. There are countless sites where a player can play and not encounter these issues.



  • "This problem could simply be solved by giving players in-game power to boot a player"
    That doesn't solve the issue though, it's just a temporary solution to a bug that's been going on for over a week. And even if they implement giving players the ability to boot others, it'll just add more problems.
    The freezing issue itself needs to be fixed, very frustrating.



  • @bleep666
    Sadly not for a week but for years. When I came here ~ 4months ago it was already present. You can find here on forum 3 years old topics complaining about this issue for example here /and here
    Reviews on AppStore, Steam speak by themselves.
    Sadly the last update made it even worse
    Imho the game never went out “Betha phase” but was put on a market anyway.



  • This just happened in my most recent game. Player “Tmerc12” played several rounds then didn’t roll the dice when it was his turn. He didn’t get skipped or anything, the timer just stayed on him indefinitely. The other 2 players and I all restarted our apps and it didn’t help. Nothing left to do but quit after 15 minutes of waiting, oh and of course that gives a win to the player that didn’t roll the dice. Not the first time this has happened and I know the developers are aware of it. What a waste of time and incredibly frustrating. I will leave a negative review online considering I paid $5 for this.


Log in to reply