• Yesterday and today we are unable to start custom games with friends. It hangs on handshaking.

  • Same here, already posted about it. It's been over a week for me.

  • Same problem here, the game hangs on handshaking. Restarting the game doesn't help.

  • @administrators Me neither, not even with AI. Keeps getting stuck on handshaking

  • Hi Guys,

    could all of you and your friends try go into the settings and disable the "Arrival of CATAN" Tutorial and let me know whether handshaking works then?

  • @Administrator I have this same problem. As advised, I disabled Arrival on Catan, but the problem persists.

  • @Administrator - same problem here. I disabled tutorial and it still gets stuck in handshaking.

  • Okay. Please try logging out and closing the app and let me know if after restarting it still doesn't work.

  • @Administrator Does not work :\

  • @Administrator I get constantly kicked :boom: as soon as a custom game starts. Automatch and Single Player work ok. Has been happening for a few weeks now, was working ok before.

  • Cak & SF - oceanië (4 players) same problem (even with computerbots)

  • administrators

    @Playdoh For a singleplayer game please use the singleplayer mode. Custom games with only one human player won´t start.

  • @Administrator Hi, custom game with 2 human players and 1 AI won't start. Even if I add the 4th player (AI), it gets stuck either on 'handshaking' or on 'searching for opponents'. What should I do? Thanks

  • @Administrator P.S. works just fine when I create the custom game from the Android app, the game starts with one AI. But it won't start from windows, regardless of who creates the game (me or wife). Thanks

  • The same issue for me too, FYI I'm using the free version.

    also while its "handshaking" I can access the store, but if I leave the store it cancels the handshaking and takes me back to game creation

  • Trying to setup Seafarers with some AI inbetween some work today and stuck on handshaking. Playing on web browser version. Tried logging in and out, making sure the tutorial is turned off and nothing seems to work. Any advice?

Log in to reply