Can’t load the game



  • I just downloaded Catan Universe on my iPad, everything was going well until I tried to start the tutorial. I’ve now been on the loading screen for the last hour, what have I done wrong?



  • Update: still waiting on the loading screen, all I want is to play Catan!!! Fix it!!



  • Same Issue for me, have tried on browser, steam and ipad.



  • Same here. Turns out I can play a game but the tutorial seems to be broken



  • Same for me. Tutorial not loading...



  • Thank you all very much for your feedback. Tutorials will be fixed with the upcoming update.



  • well I guess I won't be buying any of your alternate games since I don't know how to play the custom rules and the game doesn't have any good way of explaining anything without a tutorial.



  • Same: iOS, v1.8.5-4e08d701c



  • @Travnape Because none of these games existed as actual board games, there is absolutely no reading material online that you could read... Sorry mate. We're all frustrated, but come on. xD



  • @LunarAvenger Thats not true, these games have been around as analog board games for decades, long before online Catan. At least in Germany.
    I dont know if there is reading material online, but there is an ingame almanach, where you can read on specific topics.
    If there is a great demand for reading, us German players could translate and upload the german rulebook. But only if it is really needed.


Log in to reply