Unable to play the tutorial



  • Hi,

    I'm new to Catan and got the PC version from Steam yesterday.
    After installing I wanted to start playing. At some point you're asked if you'd like to play the tutorial, I made an error about the name of it because in the Dutch version it's called "Handleiding", So when I tied to get help on Steam I was talking about the manual :-P ...

    But I did wanted to play this tutorial and it started loading, and loading,..... and loading,....
    I got the loading screen with hint, but nothing happened, It does nothing when that strange man asks if you'd like to play the tutorial, but also when ever I start one myself.

    At one point I bought the base game, because I thought that might be the problem, but that didn't help either.

    I really would like to play the tutorial. If anyone knows how, please let me know.

    please help

    Cheers!
    First Aid Dude



  • it loads endlessly for me as well. was trying to play the tutorial for rivals of catan cause i can't remember the rules and every time i tried it just started loading something with no way to quit other than force it from the OS



  • I noticed it's not just the game I downloaded on Steam. I tried the Web-version this morning and I still can't get in to the tutorial.
    Seems like something is really broken. :-(
    So the web-version has the same error as the PC-version
    Please fix this.



  • Our team was able to find the issue and it will be resolved in the next update. Please excuse the inconveneinces



  • Thank you so much!



  • I have the iOS version, it is happening to me too. At least good to know it's not just me though! Hope it's resolved soon.



  • When is this update slated for release?

    @Administrator said:

    Our team was able to find the issue and it will be resolved in the next update. Please excuse the inconveneinces

    Thank you,


Log in to reply