Can't play online against other players due to bugs.

  • I've been playing Catan through Steam, which was pretty buggy but worked ok. A few weeks ago, the 'Auto Match' feature stopped working, and hasn't worked since. Every time I click on it nothing happens. I tried uninstalling everything and reinstalling, but with no success.

    I could still play against other players via my web browser, but today that has stopped working too.

    I pressed 'Auto match', waited to be connected, and then got a notification saying I was kicked from the game, and I was shown the login screen again. After that, whenever I click the 'auto match' button, nothing happens, just like on Steam.

    Anyone know how I fix this? Thanks.

  • This post is deleted!

  • You were kicked off the server. Just reload and try again.. or wait and try later. It will eventually work. I just use the Browser version.

  • Thanks for the reply, but I don't think it's as simple as that. It's not been working for weeks. I press 'auto match' and nothing happens. It's like my account is bugged and blocked from online games.

  • This is so stupid! The game just randomly kicked me, but when someone else lags, it doesn't kick them out of the game. Fix the damn game!!!

  • For me it works sometimes on tablet with mobile net. Wifi somehow doesn't work. Never tried it on PC since I'm already working on it all day and prefer tablet for playing.

  • @MegEgg then try to logout & in again. I got some issues solved by doing so.

  • The game will not even try to put me in a game online when I hit auto match. I have done it all uninstalled reinstalled. rebooted and still nothing.

  • Same thing is happening to me. Nothing happens, been trying for the last week. Deleted the app and reinstalled, didnt work that either.

  • Logging out and back in does NOT resolve the automatch issue (to those who suggest that) -- the very obvious resets do not work for all -- I have been having this problem for a LOOONG time ... I can play maybe one automatch, but after that the game will not allow it a second time no matter what I do - logging in & out, exiting & closing app completely, going on and doing a force quit, and even restarting my computer do not resolve the issue.
    Play Catan worked without issues as extreme as this. You could consistently play with other people online, and it was free. This is ridiculous and unacceptable. Refunds should be given to all who have purchased this game. They are clearly still working on creating this game and it has SO MANY issues.
    To put out an announcement that they're recoding is not enough.

  • I have the exact same problem.

Log in to reply