Version Issues - an easy fix instead of relying on customers



  • If your versions are incompatible and people using anything older than 1.8.2 are causing game issue, then just version lock your matchmaking so that only people with clients 1.8.2 and older can connect to each other. Stop putting this on the customer, you will continue to fail that way.

    A simple version check in your code will fix all of those problems.



  • All the problems start with the idea that players from different platforms should be able to play together. No, mobile players should not be playing with PC players if PC players would benefit much more from better suited features. Similarly in Fortnite and all Console vs PC games. Catan is not that much different. But they still do not acknowledge that. What has been said for years.


  • administrators

    @takitus That will be implemented (again) with the upcoming hotfix (1.8.3). Thanks for your patience and feedback.



  • @Stroom - I agree. Most of the time when a game is really bad, I try to ask the others what platform they use. I am on PC, they usually are on some type of mobile device.
    Going too big sometimes messes it all up..... wish they would listen to their players on some of the suggestions. This used to be a fun game ☺


Log in to reply