Updated and now displays in German



  • I just downloaded update and now everything’s in German. Is there a way to switch back to English on the app for iOS?



  • same thing happened to me! :/



  • Please uninstall the App and download it again to resolve the issue.



  • How to resolve the issue when playing from browser?



  • reinstalling the app when on my tablet does not help anything. I usually play from browser. The games are glitchy, my player profile has been reset except for ELO and everything is in german.



  • In the browser most menus are in German. Also the game is in German. How do I switch back to English?



  • Im having the same issue with the browser, text is in German and cant get it into English



  • @sandsporter1014 admin answered on another question that you can see a little German Flag :de: on the browser catan version. You should switch it to English flag.:uk: That´s supposed to give you the right version.



  • It doesnt help. Everyone I know is having issues since the server update. Not only with language settings. And both in app and browser. I really hope developers are working hard on fixing this.



  • I use the Catan Universe app on my iPad, and I just started having the issue this morning. Has a fix been discovered yet?


  • administrators

    @Kerry-O please close the App completely (meaning also closing it when it is still running in the background). After the restart, the App and the language setting will be correct again. Our team is already working on providing a hotfix for that issue. it should be available in the following days.


Log in to reply