Rivals: Mint and Great Trade Ship still not working



  • @administrators @Developers I still haven´t received a response, so I want to remind you again: The mint :moneybag: and the great trade ship :sailboat: in rivals haven´t been working :construction: :no_entry_sign: since the update before last. You can build it, but you cannot use it. :unamused:
    Please fix it! :wrench:



  • @administrators @Developers This is a serious bug, can you please respond with an ETA for when we can expect a fix?



  • Can confirm, Mint & Long Ship still not working in Rivals since update.



  • The Large Trade Ship is still not working, never played the Mint card, so I can't say much about it.
    This is a serious bug, please fix it ASAP.


  • administrators

    @vinitapioca It will be fixed in the version after 1.8.5. We finally have been able to identify what caused the issues but unfortunately, we are just wrapping up update 1.8.5 and we can´t include the fix for the cards in there.



  • @Administrator Thanks for the response. Glad the bug could be identified. Looking forward to the update after next, then. Game stability is of course the first priority.


Log in to reply