Site not loading properly anymore.



  • Site doesn't load properly.
    One the home screen I can't select anything. I press the buttons, but nothing happens. It was working fine a couple of days ago. Another weird thing, on the home screen, the background music doesn't play anymore, but there is sound. I can heard the crackle of the fire and the wind blowing, but that's all.



  • Same thing has been happening to me since Thursday. Haven't been able to play since with the exact same problem. Has anyone found a solution?



  • This is happening to me also. Click on seafarers and nothing happens



  • Nothing but problems today.... I am marked as offline yet I am playing, then nothing works. I reset whatever I can.... even reload the game,,,,, nada.
    It is so frustrating. Nobody in my family has any of these problems playing their games.... We all have Steam accounts.... jeeeesh. Ruins all the fun we could be having
    Cannot log on right now, keeps telling me I am offline...... SURE THING>



  • This just started for me today. I can't click on anything except the store. UGH.



  • The same is happening to me. I logged in today and I have the same problem. I hear the fire, and get a message 'not connected to the server. - click here to resolve'. So I click and the message goes away. So I click to start a game - but nothing happens.



  • I have had the same problems for a week - can't play through Steam or browser


  • administrators

    @Buckethead please make sure to update your Google Chome to the latest version. After that, the mentioned issue should be resolved.


Log in to reply