can't connect to server after new patch on june 5th HELP

  • anyone having this problem?? i played one game after the new patch and since then i cannot connect to the servers.

  • I cannot connect either. This is occurs on an older pc, an older mac and a brand new mac on both firefox and chrome browser. This message pops up on all possible combinations of browser and computer:

    "An error occurred running the Unity content on this page. See your browser Javascript console for more info. The error was: uncaught exception: WebAssembly support is not detected in this browser. Thanks for the help

  • administrators

    @yoxoyo please tap on your avatar, choose the option log out and then log back in again. If you need further support regarding this issue please contact us via

  • administrators

    @FremenWarrior Please clear your browser's cache and try to load again

  • Re-logging in does nothing for me - haven't been able to start a multiplayer game since the update.

  • Same problem here. Updated and then no ability to play multiplayer :(

  • Same problem. No server available message. Lof-out /Log-in does not function...

  • @BIGHOUSE @administrators @Developers @yoxoyo I can connect only for a few seconds a time. Then it disconnects, reconnects, disconnects again. I cannot finish a single game. :scream:

  • I'm having the same issue - any time I try to play on my computer it says Cannot Connect to Server. Tried logging out, tried deleting and redownloading - nothing works

  • I ended up contacting support and they suggested the following, which fixed the issue for me. Uninstall the and clean out any and all relevant folders usually found here:

    C:\Program Files (x86)\Steam\steamapps\common\Catan Universe
    C:\Users\USERNAME\AppData\Local\Google\Chrome\User Data\Default\IndexedDB\https_catanuniverse.com_0.indexeddb.blob
    C:\Users\USERNAME\AppData\Local\Google\Chrome\User Data\Default\IndexedDB\https_catanuniverse.com_0.indexeddb.leveldb
    C:\Users\USERNAME\AppData\LocalLow\United Soft Media Verlag GmbH

    Mind that you have to replace "USERNAME" with your current Windows account name.

    Then re-install the game and try again. Like I said this fix worked on my end, so I'm hoping it'll work for you.

  • Thanks for the details. I'm having to do this every time I spam the stats button as a game ends. Somehow one of these files must be left in an inconsistent state, and I'm doomed to get "Cannot Connect To Server" whenever I search with Automatch until I follow those instructions above. This will be the fifth time that I had to reinstall this weekend.

    And just in case the forum admin is ready to pass this issue onto the technical people, yes, I logged out and back in AND I restarted my PC.

Log in to reply