Desktop controls/commands



  • I began a game on my pc. I placed my initial two settlements and roads. Then, when it was time to use my resources to build a settlement or place a road, there was no way to select and place the road or settlement so, I was forced to quit the game. What are the controls?



  • Try hovering your mouse over where you want to build and clicking, and then click the checkmark to confirm (be careful not to build a road when you want settlement)

    Did you go through the welcome tutorial?



  • I did that. I hovered. I clicked. Never a check box like when you see the robber. Nothing populated. I could drag it. I couldn't click it. Nothing. No way to place the road. Also, yes, I did the tutorial.



  • @wonderwheeler Weird. I'm assuming you rolled the dice before trying to build (sometimes it lets you play road building cards or such before rolling, which is confusing)

    Are you playing through Steam or the web browser. Perhaps try the other one to see if it works for you (until Support can offer more suggestions)



  • I've never tried steam. Honestly, I have explained a thousand glitches in the mobile app so I'm honestly not surprised. Like the last three games on mobile, I'd gave the resources but couldn't build. Very frustrating. I've never tried steam. I'll look into it.



  • OK. Steam seems to be working.


Log in to reply