Mobile Platform Issue



  • @Developers Hi folks...Since this platform is the way of the CU 'future' I have tried to give it a go many times. The issue I am having is that when I log on it searches for players but doesn't manage to get any. I then log on using my laptop and no problems....am in a game straight away. Anyone else having this issue??

    As a side note: I am also having trouble (at times) with placing my road. I keep pressing on where I want to go but it won't place. Have been kicked out of several games trying this platform because of this problem. Any suggestions??

    Another side note: Should players who are trialling your 'Beta" version of mobile CU be compensated as clearly it really is work in progress and we are helping you with bug fixes etc...not the other way around.



  • @Developers ...ok so I have been trying to access the mobile platform for the past month. Still unable to log on and mentioned previously >> no probs when I log on using my lap top???


  • administrators

    @Nyte_ Have you contacted our support team via support@catanuniverse.com regarding this issue?



  • @Nyte_ I play on labtop /steam :computer: :dash: and still can login. But since last update, my friend cannot login, she plays on her phone. From what I read, the players who constantantly crash use their phones. :iphone:



  • @administrators Re: below

    @Nyte_ Have you contacted our support team via support@catanuniverse.com regarding this issue?

    No I have not (as respectfully) I rarely a get a reply. So I thought that this may be the best way to communicate.



  • @administrators @Developers It has been a while & thought that I would touch base as I have not received a reponse from yourselves. I was speaking to a few people a few days ago re: your mobile platform & they mentioned that they are having probs with it therefore have not pursued it as it was too annoying / difficult (their words). Thought / hope that you might like the feedback



  • Hello,
    I have been unable to play for a few days now on my mobile. I just get a black screen. I think this happened after the latest Oneplus system update. Any idea how to fix it?


Log in to reply