Greater Catan issue



  • Starting today, Greater Catan (seafarers) won't start properly. It started this morning when I started a new game, but the map was wrong. Three of the hexes of the main continent were water hexes but still have number tiles on them. The other (AI) players placed some of their initial settlements on the other islands (off the main continent). I quit the game and tried starting a new one but now Greater Catan won't do it. I can click New Game on the screen where the other option is Continue Game. Then when I click Start Game it either: hangs on the screen with the four characters or: goes to a solid color screen where the playing board should be.

    I have tried: shutting down Catan; shutting down Steam; rebooting my computer; and uninstalling and reinstalling Catan Universe on Steam.

    Other scenarios seem to work fine.

    Any ideas?


  • administrators

    @jrfreeze it would be great if you could reach out to our technical support via support@catanuniverse.com we would love to learn more about the issue you are describing. We may be able to help you with providing info on where to find and clear other local data (hidden) on your device that might fix that issue.


Log in to reply