Cannot activate knights

  • I have been playing catan universe for a couple of days and several times now I was unable to re-activate sleeping knights even though I had the necessary wheat / grain. Is this a bug? Any idea if and when it will be fixed? Thanks. Tine (zusje marmot)

  • administrators

    @Zusje-Marmot It would be great if you could give us more info about the issue you are currently having. Best case you do a screenshot of the situation once it happened and email to us via This will help us to recreate the situation and find out what possibly went wrong. Thank you very much!

  • I just experienced the same thing, I had a wheat and could not activate my knight. Sure enough the barbarians attacked and I was forced to lose a city because of it. I simply cannot click on the knight to allow for the option to activate it. I am using Android... I do remember this happening in the tutorial as well. I had to close out of the app and go back in and finally got it to work and finish the tutorial.

  • Ha everyone,

    I experienced the same on my iPad. However, when i tap way above the knight, around the crossroad above it, the pop-up menu for the knight does appear. It is just very inconveniently situated. I hope this helps you as well and that they’ll fix it soon.

  • Hi Everyone,

    We've checked with our QA team and we were not able to reproduce this either on iOS or Android. It would be really helpful if you could send us a screenshot of the situation, as we would be able to determine if this is any way influenced by the way your camera angle is set. Depending on the camera settings, the knight might be harder to select if your camera is set to a very low position and if there are other clickable ocjects (cities that can be upgraded etc.) directly in the foreground of the knight you want to activate.

    Or are you able to actually click on the knights but the option to activate them is blacked/greyed out?

    Thank you very much for your feedback!

  • I’m having the same issue. How do I change my camera angle to see if that helps?

  • I cannot even click on my knight to select it.

  • @Administrator I’m struggling with this issue on IOS. Try the click the knight, and the menu of knight options won’t come up. The visual trigger for the click registering is not even happening. Sometimes I can fix it if I click around for 5 mins.

    Help! I’m losing games due to this issue.

  • This happened to me today. Based on the admin replies here I moved the camera angle to be straight on instead of the low angle. That solved the issue. I will send screenshots to support.

Log in to reply