Cannot play on neither mobile app nor steam



  • I've already contacted customer support, unfortunately they could not do anything....
    I was hoping somebody else had a similar issue which he managed to solve..

    Mobile app: after login i get the "you are disconnected" message, taping on the message removes it and it never pops up again, the game does allow me to start searching for a game and to open a shop (which is usually impossible if internet connection is unavabile.
    I've tried clearing game data and cache, reinstalling the whole game, updating every single process on my phone which could be linked to online play. Nothing helped....
    Im using the same phone on which i played before, android version did not upgrade in the meantime.

    Steam: It does not allow me to log in at all. After entering my password, EULA pops out, i confirm that i agree with everything stated in EULA and then the menu freezes, it looks like the game is still trying to log in, but it does not show any message regarding connectivity. (i am able to log in on my phone, with the same username/ password)

    Browser version works as intended....

    Did anyone ever expirienced anything similar?



  • @nafrljator All the time. What sometimes helped me was

    • to go to steam :dash: homepage first, and start Catan Universe from the steam :dash: library. Doesn`t always succeed, but works about 50% for me, unlike going on steam/ Universe Catan directly.
    • To refresh the game, you can press alt and f 4 keys simultanously, and the game disappears. You end up on steam :dash: Homepage again. From there, you can quickly return to the game by pressing: play Catan Universe.
    • Another thing that helped, god knows why, is to choose another extension. I switched from C&K to Seafarers, for example, and suddenly it worked.
    • If the lost connection warning and the kicktimer :alarm_clock: appear during a game, I was sometimes able to switch it off again by flipping between chat log and game log a few times.
    • Anything else, like checkin my LAN, empting my cache, restarting my router, was absolutely pointless, because there is no technical problem on my side, the cause for the trouble is on the Catan Universe side.

  • administrators

    @nafrljator best contact our us via support@catanuniverse.com we will be able to help you get back online on the various platforms.


Log in to reply