Can't build cities since last update



  • Like the topic says. I'll build a city like I normally would, and it will show it on the board, but it won't subtract the resources I spent on it, change my score, change my resource count, or change my available cities count. And when a number that it's on rolls, I'll only get one resource. So it shows on the board as built but nothing else registers that it's built. This has only been happening since the last update along with the "you are offline" bug.

    I'm on MacOS playing through FIrefox.



  • I too cannot build cities. My ELO has dropped tremendously and I’ve tried everything I can think of to fix it. Rebooting during games, deleting the app and redoeloading; I have even gone to the extent of creating a new account with a different email. My software is IOS and I’m on an iPad. If anyone out there knows how to fix the issue, please help.



  • I bought the game yesterday but i encounter the same problem... The city shows on the map, but it didn't cost me any resources to build, doesn't grant me any point and also when the numbers are dialed i don't get the double resources. I would like this fixed soon... I pay for a game that doesn't work properly...



  • We are currently proposing to use the direct build option. Tap on the settlement you want to upgrade to a city and built in it the pop-up menu showing up then.

    Please do not drag and drop the city from the left side of the screen or try to build by tapping on the city below the board. We are still investigating what causes the issue and will release a fix as soon as possible for that.



  • @Administrator This suggestion does not work. I am at the point that I could have won a match if this problem did not exist. I am sure many others are in the same. Sure hope a fix is soon. Please and thanks.



  • @Administrator I tried the solution you suggested, and it still does not work. I have lost almost every game because I am unable to build cities, and my elo has decreased significantly. I recently purchased an expansion and thought maybe that was the problem, but since then I have deleted all apps and re downloaded, re logged in and Tryed everything. Nothing works. Please help!!!



  • I replied on the other thread but want to draw attention to this. I has been happening for 2 months or more. Incredibly disappointed by game makers. Please fix this ASAP.


Log in to reply