Loading Game on browser freezes at 75%



  • Since the recent upgrade I have been unable to connect to the game. After clicking "okay" on the initial Systems Requirement screen the loading page freezes at 75%. The browser is Google Chrome. Occasionally a Java error code appears. I updated both Chrome and Java but this has not resolved the issue. Please advise.



  • I've been having the same issue. It is to the point where I am ready to stop playing the game.



  • mee tooooooo



  • We're sorry that you're having trouble playing. The last update increased the size of the game slightly due to additions needed for the next content update. If you were already low on RAM before, this might explain the issue. If you could send us some details on your systems, we'll make sure to investigate. Also, the error code info will be helpful to identify the issue.



  • How do you defend the fact that a simple game as this requires so much RAM and CPU from the computer? Are you trying to mine cryptocurrency with this game or something?



  • Same here. Brand new laptop with 8G of RAM.



  • I have the same problem. And I am not buying this excuse. I think they screwed
    up.


  • administrators

    @al.issa.1st Are you on Chrome as well and what's the error message you receive? I've already forwarded this to the devs to check and every additional info will certainly be helpful.



  • I am having the same problem. No further than 75%. Up to Date and cleaned Chrome.

    Twice an error message came up. I will send it to you next time it comes up rather than freezing at 75%.

    Please hurry up. Catan withdrawal jitters are setting in! Hands will be too shaky to type pretty soon.

    These are my specs:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro11,5
    Processor Name: Intel Core i7
    Processor Speed: 2.8 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 16 GB
    Boot ROM Version: MBP114.0182.B00
    SMC Version (system): 2.30f1
    Serial Number (system): C02PX3XXG8WM
    Hardware UUID: 0E760517-68D1-5D6B-8DA6-9084D60F49F8



  • Tried it in incognito mode and still the same result. Rustling through all my cabinets in my house looking for that leftover pain medication from my last operation............ Please fix this soon.



  • still freezing. sometimes it goes 25%, then 50% before it freezes at 75%. never had even numbers like this before. usually odd ones with decimals. Playing it online with my mac and chrome browser.


  • administrators

    @whuffo Thanks for providing the system details, I|ve passed on the info to the devs. As you are running a quite new MacBook, I'd recommend playing via our Mac client available on Steam. The client offers better graphics and performance than possible in a browser. Of course, we'll continue to investigate the reported issue - just a personal recommendation.



  • @Administrator 8 ram. chrome and internet explorer. gets to 75% then nothing



  • On the road and I think I typed my apple password incorrectly and now locked out for setting up a Steam account.
    This is the screen I sometimes get when I try to load the game in my browser:
    "An error occured running the Unity content on this page. See your browser JavaScript console for more info. The error was:
    Uncaught SyntaxError: Unexpected token < in JSON at position 0" (my quotation marks)

    Hope you can resolve this soon.


  • administrators

    @whuffo Thanks, forwarded.

    We been testing this in internal QA today and noticed that Chrome does sometimes stop at 75% but continues to load in the background without any visual indication and then jumps to 100% and starts the game as normal. Firefox shows are more linear progression. We are still investigating this on Mac.



  • @Administrator -Thank you for looking into the matter. Yes, I've noticed that if I keep the window open it will ultimately finish loading. Unfortunately, that seems to take 8 - 10 minutes. Is there an upgrade, etc., I am able to install/preform that will speed up the load time?


Log in to reply