Device Compatibility



  • I have a Macbook High Sierra Version 10.13.3 (July 2017 model) Does this meet the system requirements for Catan Universe? It's 64 bit but I don't know if it's Quad Core processor. It's an i5 Intel processor. I don't know if my graphics card has enough RAM but I think it said 4 GB?
    The thing specifies 10.6 or newer. Does it mean 10.10.6 or newer or 10.6.0 or newer? Would mine still work if I tried?

    PS
    How do i attach a screenshot in a forum post like this?


  • Moderators

    @LeonSKennedy If you want to share screenshots with us, please upload them to a file host service of your choice and share the link to the uploaded file here in the forum.


Log in to reply