bug on arrival on catan - black screen when playing knights extension

  • Hi there,

    I have a bug when doing arrival on catan.
    after playing knight tutorial I should play a knight games... but when launching I have a black screen and can't leave the game !
    I relaunch the app but same happens again and again

  • I think our issues could be related. I was doing the "Arrival on Catan" quest, but the Cities & Knights game got stuck in the middle of the AI's turn. It is not frozen "per se" because I can interact with the interface, but the game cannot go on because its the AI's turn. I tried restarting the whole "Arrival on Catan" and when I got the last game of CaK, the game was (and still is) exactly where I left it.

    I would really appreciate it if an admin could restart my CaK game or even the whole "Arrival on Catan" quest if it's necessary.

    A possible (quick) patch that could be used would be to set a timer of 1 or 2 minutes for the AI's turn. I would say they usually complete a turn in less than 15 seconds, so that could probably work. My guess, as a programmer, would be that the AI algorithm somehow got stuck in an infinite loop (maybe due to an error in an alpha-beta search or something?).

    JanMani, the reason I believe our issues could be related is because we both keep getting the same result when trying to access a CaK game, even if the results are different for you (black screen) and me (stuck AI).

  • administrators

    @eaaa It would be great if you could attach a screenshot of the situation where you think the AI is stuck. Please upload a screenshot to a file hoster of your choice and share the link here in the forums. This will help us to figure out the issue more easily. Thanks!

  • I have the same issue, in the "Arrival on Catan" i am at the start in "Heading for new shores" , and after logging, the screen is black and in the bottom apears 15 of each resource and all, and nothing happens... please help

Log in to reply