What is up with the fixed dice rolls!?



  • After reading topics about the supposedly fixed dicerolls, I tried some single player games...

    Here are the first 9 rolls of those 5 games with different setups, scenarios and number of players:

    7,6,7,9,6,7,4,8,5

    WITHOUT EXCEPTIONS! Even the colours of the utility die was the same (pirate/yellow/green/blue)!

    I could not believe it :O

    I thought that perhaps I need to finish a game to 'finish' the seed or something. So I ended a game (fast one) and tried a new one.

    Guess what...? 7,6,7,9,6,7,4,8,5 rolls came out...

    So right now, I cannot play a single player game without knowing the exact rolls the first 10 turns... And problably more if I cared to make notes -.-

    How can this possibly happen?



  • That matches my results with the Ore for Wool scenario from earlier. The most likely explanation is resetting the seed on the dice rolling routine to fixed number. A bug like that should never get through code review, of course.

    There is some good news. I ran Ore for Wool just now and the first card drawn was no longer Road Building but rather a Knight. Unfortunately, the game then hung. It's my turn, but the end of turn icon is missing and clicking on that circle does nothing.

    My hope is that they did a hotfix in the last hour. Which may have caused the game hanging bug.

    On step at a time it seems.



  • Stuff like this should be unacceptable. It has happened before and it will happen again. And again. Something has to change.



  • Highly agreed. Something is very rotten in Denmark, as they say.


Log in to reply