Can't login to transfer Catan app expansions to catanuniverse

  • Catan HD app will not take my password from universe. I press sign in and nothing happens. I do this a few times and it switches to German but willnot take the password.

  • now I just get login failed.

  • administrators

    @Gmstman To transfer please do not go to the online part of Catan Classic.

    Please follow these steps:

    Create an CU account
    Open the CC (Catan Classic App)
    Make sure it is the latest Version 4.6.5
    Open the transfer menu (bottom right corner of the main menu)
    Enter your CU account data (press the green check mark)
    Thats it!

    If you should have trouble with the transfer please contact us via

  • @Administrator
    Same problem here. I get the remark that the account doesn't excist or the app shunts down completely!!what to do now?

  • Same here. Latest version of IOS app. Log in. Go to transfer enter my email and password then the app just crashes!

  • @Marjo24378 I did everything As mentioned in the previous solution post. I would really like a solution. The version on my IPad is 4.6.6.

  • FIXED!
    This worked for me. Go into Catan universe app and click your profile then Logout. Then open Catan Classic HD (in my case) and try the transfer again. This worked fine and when I logged back in to Catan universe my base game and seafarers were activated!

  • For me iT does workshop on my iPhone. On my IPad the password field Goes weird. All my purchases are on my iPad though....

  • OK here is what I did to solve iT. Logged out of universe and pasted my password into password field! It works now!

  • It doesn’t work. Catan classic hd says no account exists,when an account obviously does. This needs to be fixed.

  • administrators

    @Trigati Please contact our support team via . We will do our best to help you transfer from CC to CU

Log in to reply