Game chat keystrokes will accept trades and end turn



  • If I'm typing in the game chat, it will sometimes decide that my keystrokes will 1) roll the dice 2) accept trades 3) end my turn. I'm certain this is not from timing out.


  • administrators

    @PersonAD We are currently trying to reproduce the issue, but so far coulndĀ“t do it. Can you give us a little bit more info. E.g. are you using the browser or the client version? If you use the browser, which one?



  • I am using client version. It has happened in multiple games, so not just one occurrence. It doesn't always happen, but enough that I'm considering not using game chat at all. Even when it's not my turn, if I'm typing and a trade offer comes in, it'll sometimes accept it. And on my turn if I'm typing in good game or something like that, it will end my turn.



  • Just happened to a different player in a game and he said it has happened to him before. Also happened to me once more in a different game. It's fairly common.



  • Same here and I made a topic about this a while ago...

    Also avoiding using chat on my turn after client update.



  • Do you guys enter the chat by clicking the chat-window or by pressing the enter key?



  • @Administrator clicking (enter actually didn't work before).



  • Usually by clicking because I found the enter key often does not work.

    But regardless how I enter the chat. It happens when I'm already in the chat, with no trade open, I'm typing a message, a trade comes up, and it will accept the trade because of what I'm typing before I can even stop typing.

    Please also see my other post :
    https://forum.catanuniverse.com/topic/2026/everything-is-buggy-please-open-playcatan-registration



  • Another idea is to rebind the hot keys to roll, accept trade, and end turn to non-letters such as [ ] \ ; ' - = or any of the numbers. Then if the game chat keystrokes activating the hot keys error can not be fixed, then the new characters will not at least not trigger the hot key events. This should be easy to do.



  • Issue was not present with previous client version so this is something introduced in this one which made the difference.

    Rebinding key might not do the trick as for example shmug face ( :] ) still involves symbols :)



  • That's fair, but I can live without typing in emoji's. Right mow I'm tryimg to mot type the letter 'n', it's merve rackimg.



  • And for gods sake rebind the space bar to not be a hotkey. I can't not use the space bar when typing in game chat.

    Please respond admin, this is out of control.



  • The reason this is happening is, until the last update the hotkeys didn't work. Now they do, but unfortunately they have an effect even when the chat window is active. When a trade proposal comes, that popup receives the focus, and the default is the Spacebar accepts the trade offer. Obviously the most common key press during chat.

    The solution is to remap the shortcut keys. In the Client version, you do this on the little popup window that appears before the main game screen: Click on the "Input" tab there, then change the keys for "Submit a command" and "Roll dice..."

    Double click each one, then press to assign a new key. Use the weird ` key to the left of the 1 key or some other unusual key, there are plenty to choose from even if you use emojis. Tab key is an option as well.

    Not a perfect solution, but remember we're getting the use of this great game for free! In effect that is in exchange for our services as testers, and this goes along with it.



  • @DarkRider said:

    Not a perfect solution, but remember we're getting the use of this great game for free! In effect that is in exchange for our services as testers, and this goes along with it.

    This game is not great. It is horrible compared to PlayCatan. The fact that they are forcing you to test the game for them makes it even worse. The base game will be free in the end anyway.



  • This is extremely frustrating. It's hard enough there is no 'counter offer' trade available.. the ONLY current option is to discuss trades with your players. Can't even do that now because any space bar ends turn. Please remove the space bar / enter key, whatever it is that is ending turn or accepting trades.. and please bring back the option to counter trade.. Seriously.. this game.. months later.. is STILL the biggest epic fail of any 'upgrade' ever.. the old game worked.. this one doesn't.. still doesn't.. don't B.S me with 'it's free' rubbish.. just because it's free doesn't mean it's ok if it doesn't work. I never paid for the last game and if this version doesn't improve I won't even be a test guinea pig much longer. Just fix it already.. all you have to do, is make it just like the old game that WORKED.. nothing more.. nothing fancy.. just make it WORK..



  • Just another datapoint that this is happening for me too, in the browser: I'm in the middle of typing something in chat, someone puts up a trade, and hey presto as I type (and I type fairly fast, so typically haven't even noticed the window pop up before this happens) I've accepted the trade.

    Again as noted above this didn't use to be a problem, it's just since the last update.


Log in to reply