Weird multiplayer bug



  • Greetings,

    Me and my friend found an interesting  bug. We were playing multiple games together, I mean from separate PCs and with "friends" option. We just realized this afternoon that several games were starting with different maps for different players. For example, he had totally other numbers and map organization than me. 
    

    The weirdest part is that the game was functioning. We built our towns, roads and we got resources after dire roll. The stupid part from us is the fact that we did not try to go deeper in the game and quit after 4-5 turns. It would be interesting to see how the game evolves after players starting to expand.

    Anyone else experienced this issue already? Or maybe it was already posted/reported, to be honest I did not lurk about this issue at all.



  • @Mental Yeah, this issue happens a lot. Rarely does a game finish with it - though you can get quite far in. Usually it freezes, forcing the person to reset. They then realise the board was completely different, as it now shows 'correctly' whichever version that is. But game usually still stuck. It is a totally weird bug.



  • Btw @administrators We just had this happen again, and we all chose to play on (out of curiosity). It turned out that only one player was seeing the "correct" board (as measured by what it reverted to when everyone refreshed). Interestingly, everybody still had the cards from the original board they had seen. So one player, who had no brick on the refreshed 'actual' board, was still holding two brick cards even when seeing the proper board. Not sure if that helps with working out what glitch is?

    (Also, one of the players was shown as a different colour entirely on the incorrect board)



  • I'm getting a sense that the board info is stored locally. This way all out of sync errors will remain after refresh. This game is a board game and sending all relevant info to all players should be really simple. Even after each turn has begun.

    Unless the backend is really messed up and doesn't validate user input or something. I am amazed how we can see new bugs after updates which are irrelevant to what the update changelog mentioned. Something fishy is going on here.



  • Thanks for your report! I've already forwarded this to our developers to investigate. Could you please let uns know:

    • Which version ofthe game did you first notice this in?
    • Did this happen in custom games only or in all multiplayer game modes?


  • @Administrator I now play primarily the desktop client, and it happens regularly. Although, I feel like I may have first noticed this in the webclient? As I only started playing the desktop client recently, and have been aware of the issue for a while it seems.

    I usually play auto-player, and it is there that I have noticed this issue.



  • This issue is still happening on the web browser version. FYI.



  • is there a maintenance going on? https://catanuniverse.com/en/game/ has been unreachable for the last 30+ minutes.

    This site can’t be reached
    catanuniverse.com took too long to respond.



  • I've just signed my wife and I up to Catan Universe. Everytime we attempt to start a game, the board that appears for me (on my android tablet) is different to the board that my wife gets (on PC via web). Very frustrating, I was looking forward to playing games with my family spread across the country, and isolated at the moment.



  • I just played today with my girlfriend and we had the exact same problem.
    We tried 3 times to play, the 2 of us and 1 computer player.
    We were seeing completely different board organizations, the desert tile was in a different place etc.
    The 3 games ended up freezing after a few turns. On my screen it looked like my turn was over and it was my girlfriend's turn, but she couldn't play, on her screen it looked like I was still not done with my turn.

    How do you guys "refresh"???? I would really love to be able to play...



  • I just got this issue today as well. We have 3 players and are on Catan Universe 1.8.9
    We have 3 players in the game, 2 were synced correctly and the third player had a different board. We quit and started a new custom game and had the same problem the second time. At this point we asked the 3rd player to completely restart the game and tried again. This seemed to fix the issue at least for now.

    Is there any update on this issue @administrators ? This was brought up 4 years ago and seems like it was never fixed. Please let me know if I can provide logs or additional information.



  • Yup, still happening. With this the game is unplayable, can we get our money back? @administrators



  • Yes,
    Also reviewed here and here (at least).

    In my case the issue has occurred on every multiplayer attempt when playing with 1 player on the web-client and 1 on the mobile app (and one AI), whichever the host, whichever the options of the game.
    We tried again both on mobile app (Android and iOS) and the maps were this time identical on all the games attempted (4/4)
    (Then we encountered the freaking annoying dice bug, but this is another topic)

    Please @administrators @Developers, release a tiny update to fix this !
    I can provide any information, screen capture videos or pictures that you may find useful.

    Thank you very much, let us know if we can help !



  • This bug *still ** happens. The map you are seeing is the map from your last (probably unfinished) *game.

    It happened to me when I left the initial AI game and tried to play a multiplayer game with friends.

    The old pam persisted until I restarted the game


Log in to reply