Indefinite waiting for new game...



  • I am aware that this thread will start a litany of the usual complaints, however, it really has become a major issue: I haven't been able to get an auto-match game at all now, either last night or this morning.

    I have tried everything: checking the options I wanted and waiting (15 minutes later I gave up); keeping all the default options and waiting (only got as far as 10 minutes before I gave up); cancelling the wait and starting it again; restarting the game again completely (alt+F4).

    Nothing. No game. The one game I did get (as I wrote this actually), turned out to be a blank board error.

    This used to happen before the update, although not as pronounced. Usually, cancelling your waiting list and signing up again would work. Also, when that happened, you would usually see the number of players 'correct' itself - now, the number of players listed as waiting is correct (doesn't change when you reset the wait), and goes up and down (usually around 5-9 players waiting; 7 being most common), but still no game.

    (As a side note, someone else has actually posted in english about this already, but I could not find the thread again)



  • @administrators - I JUST got a game, after shutting the desktop client down completely and waiting 5 minutes until I restarted it. Not sure if that info helps with the issue? I don't know whether it is a glitch, or just the time needed to find the best match, but resetting the client (with a wait) seemed to fix it



  • Just had same issue again - let it go out of curiosity. 20 minutes and no game.

    Cancelled and reset the wait list. The numbers of people waiting I had been seeing were different to the "refreshed" numbers after I cancelled.

    Started again, and then got a game in 2 minutes.

    Not sure if all this helps?



  • Lobby. You do not have enough players for a matchmaking system.


  • administrators

    @BlueMythril Thanks for the feedback. We are investigating what could be the causes for the difference in the waiting time if sufficient players are avaiable.



  • @Administrator Cheers - having the same issue again today 9-12 players listed for the last 10 minutes yet no game starts



  • @BlueMythril Finally got a game (again, after resetting it and just using the default settings), only to get the "error request already processed bug" and have the game freeze up on me.

    Got a second game after that too (again using the default settings), only to get the blank table.



  • @administrators 45 minutes today and no luck getting a game. 8-10 players available at any given time. None of the little things I have been doing (leaving it at default options, or setting it to 'friends' - this last usually has better luck kicking into a game even if no friends listed as waiting) worked this time.

    Have given up and closed the client for today :(



  • @BlueMythril said:

    @administrators 45 minutes today and no luck getting a game. 8-10 players available at any given time. None of the little things I have been doing (leaving it at default options, or setting it to 'friends' - this last usually has better luck kicking into a game even if no friends listed as waiting) worked this time.

    Have given up and closed the client for today :(

    Just cancel the search and search again. I do this every 30 seconds. Normally a game starts immedialtely.



  • @Insanius That's also one of my usual tricks. For some reason it just didn't work last night.



  • Been playing for about a week with minimal issues all things considered.

    Past couple of days the game wont load after the loading bar complete. Just get the orange screen and after awhile this message

    An error occured running the Unity content on this page. See your browser's JavaScript console for more info. The error was:
    Uncaught TypeError: Cannot read property 'canvas' of null

    Running Macbook pro OSX 10.10 using google chrome

    tried clearing cache and opening incognito tab rebooting but no change



  • @administrators Any update on this issue? Been impossible for me to get an automatch game started in the last hour +.

    I eventually gave up and just played single-player. No problems there - the game play was blindingly fast (except for the jarring delay of the robber animation - you really notice that delay more in singleplayer now with the faster animations). I tried every little trick that usually seems to work in getting a game to start in auto-match, but nothing.

    Also, each time I cancelled (sometimes after a few minutes, usually after after 5-10 minutes, once after 20 minutes), the number of players listed as waiting was out of sync (changed to a different number immediately upon cancelling).

    (Also, had everything else on the computer closed - just running Catan, memory wasn't even at 50%, so not that issue).


  • administrators

    @BlueMythril

    I'll check with our dev team if there was any specific problem with the game servers or backend last night.

    There are still some issues with matchmaking, esp. the number of available players not always refreshing correctly. However not being able to start a game for an hour sounds more like a bug. Did you happen to play another multiplayer match before that matchmaking issue happened, or did experience this right after logging in?



  • @Administrator Usually it is just after logging in. Once I get a game, i rarely have this issue after



  • I have the same issue daily. Either I get a game right away or I can be waiting hours and get nothing: there is no in between. The number of available players can be 10 or more and yet no game.
    I have to constantly go back to the game setting window (which doesn't keep my request) and re-set everything then relaunch: again either I get a game right away or never.



  • I am finally able to login again. So my disappointment was great, when I was unable to get a game. I checked all options, but no success. Supposedly there was a changing number of players available. (Changing back and forth between 1-2-3- 4.) How come?


Log in to reply