Logging into the client



  • Excuse me if my techno language is wrong but basically I got sick of the browser version of the game freezing and then literally taking 5 min to load after I refresh the page so I decided to download the client. After installing the program I tried to log in using my details (and I know for a fact that they are correct) I received the error message ' KNF: Network _ClientVersionTooOld

    Any idea what I should do?


  • administrators

    @jtothe9 After downloading the installer the game needs to be started by the launcher (this is usually done by the Catan icon on your desktop). The launcher will then automatically download the latest update required to play.



  • I've tried launching the Launcher and get a 'Vorgang wurde abgebrochen' message. It seems that it cannot connect to the server to update?



  • @Administrator forgot to reply to your message


  • administrators

    @hibikidan333 Does your internet connection work fine otherwise? This sounds like a connection problem. But the servers are up and running and the connection tests show no error on the server.



  • @Administrator Yes, I am on a cable connection. I re downloaded the game and re-installed it and still it gives me 'Vorgang wurde abgebrochen' after I run the desktop version launcher


  • administrators

    @hibikidan333 Could you please let us know what your cable provider is an where you are located (country)?



  • @Administrator Telstra, Australia.



  • @Administrator Any updates on the progress? Is there a log file I can submit to help?


  • administrators

    @hibikidan333 Regrettably we haven't been able to identify any connection issues. What version of Windows are you running and are there any "unusual" factors involved, e.g. a virtual machine or something like that?



  • @Administrator Windows 10 64 bit

    So is there a log file I can submit that could debug what's going on?



  • I am having a similar problem, after the launcher looks like it has finished, an error message appears:

    FEHLER

    Updatedatei konnte nicht erstellt werden.

    I am running Windows 8 in California and my connection is fine.
    I can connect to the browser version just fine as well.

    Edit: i just solved it. i right clicked the catanlauncher.exe and clicked "run as administrator", which caused installation to happen again in a new location with a new catanuniverse.exe, which can log in now.



  • I got the exact same problem.
    Now that 'Smiles' helped me with the 'Run as Administrator' trick, I can log in, but after I enter the user and password and hit Log in the application stops working.

    Sorry to say that, but the game as it is now looks like shit.
    This is far away from a beta version. I don't really understand why don't you hire a couple of QA guys to test it before releasing it.
    In my experience the end-user is not the appropriate person to test the application.

    As it is currently, I don't feel motivated to play your game, even if I am a Catan fan.


Log in to reply